Monthly Archives: August 2014

Perl lib version (v5.8.8) doesn’t match executable version (v5.10.0)

Issue while running adcfgclone on target database node, I can see below error messages in logfiles..

ERROR:

perl adcfgclone.pl dbTechStack
RC-00110: Fatal: Error occurred while relinking of ApplyDBTechStack
Perl lib version (v5.8.8) doesn’t match executable version (v5.10.0) at /usr/lib64/perl5/5.8.8/x86_64-linux-thread-multi/Config.pm line 46.
Compilation failed in require at /u01/oracle/product/11.2.0/appsutil/clone/ouicli.pl line 35.
BEGIN failed–compilation aborted at /u01/oracle/product/11.2.0/appsutil/clone/ouicli.pl line 35.

AutoConfig is exiting with status 1

RC-50013: Fatal: Instantiate driver did not complete successfully.
/u01/oracle/product/11.2.0/appsutil/driver/regclone.drv

SOLUTION:

1. Make a backup copy of your existing Database Contextfile.

2. Modify the context file as shown.
BEFORE :

<PERL5LIB oa_var=”s_perl5lib” osd=”unix”>/<complete path>/db/tech_st/11.2.0/perl/lib/5.8.3: \\
/<complete path>/db/tech_st/11.2.0/perl/lib/site_perl/5.8.3:/<complete path>/db/tech_st/11.2.0/appsutil/perl</PERL5LIB>

AFTER :

<PERL5LIB oa_var=”s_perl5lib” osd=”unix”>/<complete path>/db/tech_st/11.2.0/perl/lib/5.10.0: \\
<complete path>/db/tech_st/11.2.0/perl/lib/site_perl/5.10.0:/<complete path>/db/tech_st/11.2.0/appsutil/perl</PERL5LIB>

3. Execute Autoconfig to get the modifications implemented.

 

Thank You!!